• Hello Guest, welcome to the initial stages of our new platform!
    You can find some additional information about where we are in the process of migrating the board and setting up our new software here

    Thank you for being a part of our community!

240+T walbro in tank pump install

Jressman

Member
Joined
Jan 4, 2015
Should I wire this Walbro 450 like the OEM pump and ground it to the assembly and solder the power wire to where the factory wire goes under the stock plug, or just run all new wiring up and out the top?

Using maxxecu instead of factory ECU
 

culberro

Ronald Culberbone III
Joined
Feb 10, 2010
Location
Redmond, OR
The factory wiring will not support a Walbro 450. It needs a large gauge dedicated power wire and relay. I ground mine in the trunk using the OEM spot. It was all done with 12 or 14ga wire.
 

Jressman

Member
Joined
Jan 4, 2015
I was able to get the pump physically in the assembly. I had to cut 1.25” off the hard pickup line with a dremel. I was able to use the stock rubber flex hose. I cut the bucket for the stock pump and stretched it wide enough to hold the Walbro and secured it with a stainless hose clamp. I’ll run the wire harness out the top and clip the old wire leaning just the fuel level sender wire.
 

Attachments

  • FC55FC04-5E15-406F-9FFA-3A1164181E9E.jpeg
    FC55FC04-5E15-406F-9FFA-3A1164181E9E.jpeg
    348.4 KB · Views: 20
  • 59B93DB6-1242-49B9-9D9C-ECFE1C8439CC.jpeg
    59B93DB6-1242-49B9-9D9C-ECFE1C8439CC.jpeg
    298.3 KB · Views: 20

Dvroofer

Member
Joined
Jan 23, 2021
Location
Long Beach,ca
Does anyone have a reference thread to the actual re-wiring that needs done. I know I did mine to delete the inline but am second guessing if it is 100% correct
 
Top